Billing system issues
Incident Report for Atlassian Bitbucket
Resolved
Our billing platform team has mitigated the issue and all users should again be able to view their billing estimate/usage, change their billing plan, and update their credit card information. If you experience any further issues, please contact support at https://support.atlassian.com/
Posted 3 months ago. Jun 20, 2017 - 21:07 UTC
Identified
The Atlassian billing platform is currently experiencing issues. As a result, users may not be able to view their billing estimate, change their billing plan, or update their credit card details at this time.
Posted 3 months ago. Jun 20, 2017 - 19:09 UTC
This incident affected: Website.